clarson at kergoth.com
Tue Mar 23 16:36:27 CET 2010
On Tue, Mar 23, 2010 at 2:50 AM, Holger Hans Peter Freyther <
holger+oe at freyther.de <holger%2Boe at freyther.de>> wrote:
> On Tuesday 23 March 2010 10:32:59 Frans Meulenbroeks wrote:
> > Chris, while this is a nice idea it conflicts with having checksums in
> > the recipe, as that makes the recipes unique.
> > Unless of course there is (or we create) a way to have multiple
> > checksums in a recipe and pick the one that is for the version we are
> > building.
> There is a way or could be a way. For the name= we can use a variable in
> name (e.g. PV) but have a written out variant for the SRC_URI.
Good idea, didn't think about using the version as the name or part of it,
that could alleviate the need for the anonymous python snippet I'm using at
the moment. (Aside: it would be nice if you could set a flag on an override
variable (FOO_arm) and have that flag be pulled over to the main variable
(FOO) at override collapse time, but BitBake does not do it today).
clarson at kergoth dot com
Founder - BitBake, OpenEmbedded, OpenZaurus
Maintainer - Tslib
Senior Software Engineer, Mentor Graphics
More information about the Openembedded-devel